https://authzed.com logo
#spicedb
Title
# spicedb
u

__alexb__

10/19/2022, 11:36 PM
Hi everybody, we're randomly getting this error when using SpiceDB with Postgres as a datastore
Copy code
{"level":"error","requestID":"4fb88c480756c86269cef27e5015b574","error":"unable to read namespace config: context canceled","time":"2022-10-19T23:01:14Z","message":"received unexpected error"}
 {"level":"error","grpc.component":"server","grpc.method":"CheckPermission","grpc.method_type":"unary","grpc.service":"authzed.api.v1.PermissionsService","peer.address":"192.168.32.4:46070","protocol":"grpc","requestID":"4fb88c480756c86269cef27e5015b574","grpc.start_time":"2022-10-19T23:01:14Z","grpc.code":"Unknown","grpc.error":"unable to read namespace config: context canceled","grpc.time_ms":"29.173","time":"2022-10-19T23:01:14Z","message":"finished call"}
the same issue was mentioned here before by a couple of people, but I didn't find any advice how this can be solved. Just like in the previously reported cases we started to get this issue in integration tests. Switching to
serve-testing
helps with the tests but we've seen the same error a couple of times in the live system as well. We've tried to adjust lots of settings like SPICEDB_NS_CACHE_DISABLED, SPICEDB_DATASTORE_MAX_TX_RETRIES, etc., but nothing has made our tests reliable. The tests aren't heavy at all, we create less than 100 relatioships and do various calls to check permissions and lookup resources. We run them using docker-compose and the official SpiceDB Python client. Any hints would be really apreciated.